Install Flash (Frash) easily on your iPhone 3GS/4 with a Cydia Repo

We covered Frash’s arrival to iPhone earlier today. It involved a lengthy process of SSH-ing into your iPhone using a PC or Mac and then copying the frash.deb file into a folder, after creating a couple of folders. The whole process has been made as easy as adding a Cydia repo and installing a package.

flash-on-iphone-ipad-ipod-touch

Here are the full steps:

  1. Make sure your iPhone is jailbroken. Read more here.
  2. Open Cydia. Go to the Manage tab > Sources.
  3. Tap Edit and then add.
  4. Add this source http://repo.benm.at Frash on iPhone 3
  5. Go to search and type in Frash. Install it. Frash on iPhone

That’s it. Now you’ll be able to view some flash content such as ads and games in Safari. If you use SBSettings, you can also install the Frash Toggle which will let you enable or disable Frash easily.

Thanks for the tip Mike!

Update: Installing Frash using this method also works fine on the iPad. Thanks to Matthew for confirmation on our Facebook Fan Page.

Update 2: As it turns out, Frash only runs on ARMv7 processors which iPhone 3G doesn’t have. Sorry guys, you’re out of luck.

Tagged:
About the Author

Technology enthusiast, Internet addict, photography fan, movie buff, music aficionado.

54 comments

  1. Frash requires Arm7 processor, so don't bother trying to install on older iPhone 3G models (MB models).

  2. Pingback: Tutorial: Get Flash On Your iPhone Or iPad In 4 Easy Steps | GoodGadgetBadGadget.com
  3. Pingback: Benm.at adds Frash (Flash) to repository, makes installation stupidly simple | bigBrains.com
  4. Pingback: Flash (well, Frash) now works on your jailbroken iPhone 4 | ThaiDC.com
  5. Pingback: Tips and Tricks « Joseph Lo's Web Notes
  6. Pingback: Install Flash on iPhone in three simple steps
  7. Pingback: Install Flash Untuk iPhone/iPad (Frash) Melalui Cydia
  8. Pingback: Download Chip.eu » Blog Archive » The Easier Way to Install Flash on iPhone 4 and iPad
  9. Hi
    Can you compile it again but change arm7 to arm6. Then it will maybe work on iPhone 2G, 3G and iPod Touch 1G, 2G. You can change arm then you go to “get info”!!

  10. Pingback: The Easier Way to Install Flash on iPhone 4 and iPad | Are You Reading!
  11. Installed Frash on my 3gs and it doesn’t work!!! and now with safari doesn’t work also wacthing video on youtube.com… Help…?!

  12. trying to load Stattracker from yahoo fantasy and safari crashes.. I mean it does start to load the flash.. but it crashes.. need to try with something else

  13. Hii i have iphone 3gs and i installed frash but when i wont to play any vedio the box of vedio become ( unexpected error ) and still dosnt work . What can i do????
    Thanks

  14. Pingback: Flash player for your iPhone 3gs and 4 « KingBerly Grapx.
  15. Does not work on IOS 4.2.1 on iphone 4.
    Keep getting the error message “Wrong language code en-GB” and therefore will not add the app.
    Gayyyyy

  16. Frash doesn’t work with jailbreacked iPhone 4 (IOS 4.2.1). Jailbreacked this morning with GREENPOIS0N.

  17. I am having issue with frash. When I click flash, it said unexpected / abort and no video shown. I am using iPhone 3GS with 4.3.3 firmware.

  18. I tried this on my iPad… it didn’t work.i am not sure if these instructions were for iPad?!?! or were they?

Leave a Reply

Your email address will not be published. Required fields are marked *