unc0ver 6.1 jailbreak is now available with improved iOS 14 support

unc0ver 6.1 jailbreak tool update is now available with improvements to iOS 14 support. The developers have been hard at work and have released 3 updates in just 5 days since the tool was first released. This new unc0ver jailbreak has been popular for the fact that it can jailbreak iOS 14.3 on all devices, including the latest iPhone 12 series and iPad Pro models. The tool supports iOS 11.0 – iOS 14.3, allowing it to cover even older devices such as the older iPhone SE.

unc0ver 6.1 iOS 14 iOS 14.3 jailbreak

Download unc0ver 6.1 with stability and reliability fixes for iOS 14

unc0ver takes advantage of CVE-2021-1782 vulnerability which Apple fixed in iOS 14.4, however, it gave the jailbreak community a rare opportunity to be able to jailbreak every iPhone and iPad model that is on iOS 14.3 or earlier releases.

Version 6.1 includes a number of stability and reliability fixes for users on iOS 14.x versions. It also fixes a known bug that caused the uncv0ver app to show incorrect jailbreak settings after you jailbreak your iOS 14 device.

Here are the complete release notes for unc0ver 6.1:

  • Fix all known stability and reliability problems on iOS 14
  • Fix a bug that caused the unc0ver app to show different jailbreak settings when opened in the jailbroken state on iOS 14
  • Add custom libkrw plugin to enable kernel read-write support on iOS 14 for security researchers and developers

To upgrade to unc0ver 6.1, you will have to use AltStore, Xcode, or Cydia Impactor to jailbreak your device. If you had already jailbroken your iPhone or iPad with unc0ver 6.0.0 or 6.0.1 before, you can simply download and install ReProvision from Cydia, download the latest unc0ver IPA, and install it to re-jailbreak your iPhone or iPad.

You cannot use unc0ver to jailbreak your iPhone or iPad if it already updated to iOS 14.4 or iPadOS 14.4. Fortunately, you can still jailbreak iOS 14.4 by using checkra1n on some older iPhone and iPad models. checkra1n currently supports the following, with more devices to be supported soon:

  • iPhone 6s, 6s Plus, and SE
  • iPad 5th generation
  • iPad Air 2
  • iPad mini 4
  • iPad Pro 1st generation
  • Apple TV 4 and 4K

Read more:

About the Author

Technology enthusiast, Internet addict, photography fan, movie buff, music aficionado.

Leave a Reply

Your email address will not be published.